Andrea Beggi

When it is dark enough, you can see the stars.

L’avrei dovuto capire subito…

A T T E N Z I O N E ! Questo post ha piu' di sei mesi. Le informazioni contenute potrebbero non essere aggiornate.

Da ieri mattina WordPress non mi manda più gli avvisi di nuovi commenti via mail, anzi all’inserimento di un commento l’utente viene rimandato ad una pagina bianca. Scocciato assai, mi fiondo sul sito gratuito dove tengo un’installazione di prova di WP, sulla quale testo tutte le modifiche prima di passarle “in produzione” (qui siamo professionali, che credete?), ricopio files e template, reinstallo tutto il database che uso qui, e tutto funziona perfettamente. Che fare? Dopo aver googolato per un po’, trovo solo una segnalazione, ma nessuna soluzione. Ripasso tutto il template, alla ricerca di tag aperti e/o errori, ma nisba. Mi rassegno a disattivare la notifica e posto un messaggio sul forum di supporto di WP.
Stamane mi scrive Cristiano: anche lui ha lo stesso problema, sullo stesso hosting!
Immediata richiesta al supporto di WebPerTe che, velocissimo come sempre, mi risponde:

Salve, abbiamo riscontrato un bug sull’ultima versione del PHP; non
funziona il mail(). Stiamo cercando una soluzione a breve, mi scuso per il disagio arrecato.

Come al solito penso sempre che sia colpa mia, e prima di chiedere lumi mi sbatto all’inverosomile, salvo poi realizzare che mi potevo risparmiare la fatica.
Mi devo anche scusare con Zuppah e DElyMyth nelle cui caselle email ho frignato senza ritegno.

5 Commenti

zuppah | #

con me no di certo! sono io quella che frigna nelle caselle di posta altrui 😀
[io non avevo il servizio abilitato, per questo sembrava fosse tutto a posto!]

Antonio | #

Non so se sia cos saggio utilizzare mail(), comunque. Non meglio una classe smtp?

ciao

Andrea Beggi | #

Non una cosa su cui si possa avere controllo senza mettere le mani nel codice, cosa che non sono in grado di fare….

Alessandro Ronchi | #

Io uso wordpress e dalla nuova versione non mi funziona pi l’email, ma uso aruba. Quello che mi chiedo, a questo punto, se la vecchia versione utilizzasse funzioni diverse per l’invio di email.

Andrea Beggi | #

Io uso 1.2 mingus, ed ha sempre funzionato. Ha smesso senza che toccassi nulla, quindi non credo dipenda a WP.