Andrea Beggi

Perché non si può essere sempre la parte migliore di noi stessi.

Aggiornato WordPress

A T T E N Z I O N E ! Questo post ha piu' di sei mesi. Le informazioni contenute potrebbero non essere aggiornate.

La versione 2.0.1 di WordPress non mi piace. Non so ancora perchè, ma c’è qualcosa che mi disturba.
La cosa peggiore è che su OS X non c’è un browser con il quale funzioni bene: Safari e Opera non visualizzano correttamente l’interfaccia dell’editor, e Firefox apparentemente non è in grado di salvare le modifiche ai post; cioè mi dice che sono state salvate ma è una bugia.
Con tutti e tre i brower, il salvataggio del post è lentissimo. Qualcuno ha per caso gli stessi problemi?
Inoltre mi piacerebbe non reinstallare Trencaspammers, che costringe a copiare il codice antispam, cosa che tutti odiano, ma WP-Hashcash litiga con Askimet. Se attivo il primo, su OS X non riesco a commentare con Firefox, se attivo il secondo devo comunque cancellare i commenti che finiscono in “quarantena”.
Mah (c).

29 Commenti

Fringe | #

be’… sono in buona compagnia.
Non mi piace l’idea dell’anteprima del post. Per caricarla si rallenta tutto.
Non mi piace l’editor WysiWyg. Quello che avevo prima non era il massimo ma funzionava meglio.
E’ vero che il salvataggio e’ lento ma credo che dipenda dalla anteprima.
La gestione delle immagini e’ geniale ma l’invio all’editor funziona una volta su 5.
Trencaspammer, come sai, non mi da’ problemi ma io Askimet non l’ho installato.

curson | #

Io ho il problema che hai indicato con l’editor+Opera 8.50 (problema risolto con Opera 9 Preview2, solo che ancora non ho il coraggio di installarlo “di base”) soprattutto per quanto riguarda l’utilizzo del mouse. Personalmente ho disabilitato l’interfaccia WYSIWYG ma comunque mi rimane impossibile usare il mouse per le selezioni di testo all’interno del riquadro degli editor, sia durante l’edit di un post (nuovo o vecchio) sia durante l’edit delle pagine. Ho la 2.0 di WordPress, e ora che so che non è stato risolto nulla con la 2.0.1, eviterò l’upgrade.
Per il resto funziona tutto a dovere (la lentezza nel “salvataggio” del post la avevo già con la versione precedente, l’ho sempre imputata all’SQL di Aruba, e poi non è esageratamente fastidiosa… almeno per me) e non ho riscontrato problemi, anche se ritengo che l’admin panel fosse meglio nelle versioni precedenti. Ma sono uno a cui i “fronzoli” piacciono poco 🙂

Stefano | #

I problemi con Safari sono noti, ma con FF solitaemnte non vi sono problemi, mlto strano la cosa sulle modifiche non salvate. Hashcache non è fra i plugin indicati come compatibili 2.0, anche se c’è una beta in fase di sviluppo.

Akismet mantiene lo spam per 15 gg. poi lo cancella automaticamente, ciò per permettere di verificare eventuali falsi positivi.

Alcuni dei problemi che indichi potrebbero dipendere da plugin non compatibili al 100%?

Vanessa | #

Io ho installato un’altro editor, perche con quello di WordPress proprio non mi trovo.. e con questo nuovo devo dire che roxa parecchio WP ( chenpress ) lo sto usando nel nuovo blog quello che sostituirà layoutstudios..

Tambu | #

anche io voto per Akismet!! da quando cell’ho vivo sereno… quando ho tempo butto un occhio ai falsi positivi, e poi ROARRRR!! azzero 🙂

Fringe | #

Vanessa, scusa ma quale e’ l’editor che usi?

Mauro | #

Secondo me WordPress 2 è ancora un tantino acerbo, soprattutto per chi ha un blog già avviato e funzionante.
Come curson anche io qualche volta ho pensato che la causa della lentezza del salvataggio dei post dipendesse dall’sql di Aruba, ma non è così. Il database viene aggiornato in tempo reale ma a volte WordPress sembra andare in stallo, soprattutto con Firefox.

Luke | #

Anch’io ho dei problemi quando sto per postare mi esce questo errore anche se il post viene pubblicato correttamente. Ho provato a togliere i plug-in e a reinstallare wp ma niente

WordPress database error: [Lost connection to MySQL server during query]
INSERT INTO wp_postmeta (post_id,meta_key,meta_value) VALUES (‘211′,’_encloseme’,’1′)

Andrea | #

Stefano, i plugin che uso sono:
Askimet
Paged Comment Editing
Favatars
Search Hilite
Feedburner Feed replacement
Technotag
Dovrebbero essere tutti compatibili, e comunque nessuno di questi dovrebbe intervenire in fase di pubblicazione….
E di HashCash usavo la beta 3 che dovrebbe andare…
Da notare che con windows non ci sono grossi problemi, è con OS X che è un disastro, mentre prima era perfetto.

Giorgio Zarrelli | #

Hashcash beta 3 non mi da problemi con WP 2.01, trencaspammer si, con K2. La preview, è vero rallenta e il posting, ma solo in fase di pubblicazione, risulta lento, come era lento nella 1.5, per me. Nessun problema con Firefox, né sotto Linux, né sotto Windows. Mentre mi ha dato problemi il feed dei post, che a quanto pare ha dato problemi ad alcuni e ad altri no.

Forse un problema di javascript in OSX?

Fringe | #

se puo’ servire a me trencaspammer non da’ alcun problema.
ne’ hascash 3.0

stefigno | #

personalmente a me da problemi, con l’inserimento immagini ed askimet, non è il massimo della velocità , nel senso che globalmente la situazione si è rallentata, ma ringraziando qualche divinità le cose sembrano funzionare bene. van , qual’è il tuo editor..? Lo vorrei provare anche io..

PseudoTecnico | #

Io non ho notato particolari problemi con WordPress 2.0.1 😕
Nei giorni scorsi ho scritto post con Firefox 1.5.0.1 e WinXp e Os X senza intoppi 😉

davidonzo | #

Se il problema è l’editor e la gestione dei media si potrebbe provare ad installare FCKeditor.
Non è che sia il massimo, ma ad utenti mac funziona bene, o almeno così mi hanno detto…
Ha anche la funzione per l’upload dei file, con gestione visuale degli stessi…

Lo so che penserai “E se ora gli metto questo, che ho aggiornato a fare?!”, ma è l’unica cosa che mi è venuta in mente…

Giovy | #

Io sono fresco fresco di aggiornamento alla 2.0.1, e non ho rilevato particolari problemi con Firefox.
L’invio dei post funziona senza problemi (magari “impalla” FF per qualche secondo, ma niente di che), così come tutte le altre funzioni.
Unico “bug” che ho riscontrato è che se vado a vedere il tab “Opzioni/Permalink”, mi si blocca l’accesso al blog (perchè viene modificato il file .htaccess) anche se in realtà non modifico niente.
Come editor di testo uso Xinha per WordPress (http://www.giovy.it/2005/12/21/xinha-per-wordpress/), che funziona benissimo ed è anni luce avanti rispetto all’editor integrato (che va disabilitato per far funzionare questo secondo editor).
Comunque, direi di essere soddisfatto appieno della versione 2.0.1.

franto | #

La cosa che odio di più è l’editor WysiWyg, semplifica un po la vita ma ogni tanto si prende delle topiche allucinanti sulla chiusura della formattazione del testo e sputtana mezzo blog!!! Inotltre avete mai provato a fare un copia-incolla da un documento di OpenOffice-Word sull’editor? un consiglio non provateci!

Concordo anche sul fatto che la velcità di caricamento dei nuovi post è lentissima!!!

per quanto rigurda il resto non ho avuto problemi.

Tambu | #

Andre, ti smentisco sulla questione dei plugin in pubblicazione!!

ti ricordi quel problema noioso di cui ti ho parlato a InEdita? beh, alla fine col classico metodo del metti-leva-metti-leva ho scoperto che il problema era nel plugin Extended-live-archive… e manco quello DOVREBBE intervenire in fase di pubblicazione/modifica… eppure… aggiorato quello, sparito il problema!

Andrea | #

Tambu, era solo un’ipotesi, non sono mica sicuro che non diano fastidio. Però li avevo anche prima e dovrebbero comunque essere compatibili con la 2.0.1

Vanessa | #

L’editor che uso è chenpress Fringe

Barbara | #

Anche a me non fa impazzire sinceramente ma non ho avuto
particolari problemi, lascio Trenca e pace finora è
sicuramente la soluzione che mi ha dato meno problemi e
filtrato meglio lo spam ( quasi del tutto scomparso)

Mauro | #

Franto prova a copiare il testo prima su blocco note e poi in wordpress. La formattazione di OO-Word viene annullata e il risultato è ottimo.

franto | #

Lo faccio di gia’ Mauro!
comunque grazie per la dritta! 😀

kOoLiNuS | #

ma che charset hai selezionato ?

se lascio firefox a UTF-8 vedo tutte le accentante ad minchiam ….

davidonzo | #

Koolinus: a me sta cosa succede in tutti i siti che vedo da linux con FF, Mozilla, Epiphani…
Il problema è che per scrivere correttamente la e accentata si dovrebbe far ” &egrave ” e si ha la è con l’accento grave, e così via per tutti.
Il wysiwyg che uso io lo fa di suo. Digito da tastiera e lui scrive in codice il giusto corrispettivo…
Forse quello di WP non lo fa?!

davidonzo | #

sorry per lo spam, ma ho sbagliato a scrivere 🙁

à
è
ì
ò
ù

Dimenticavo il ; sopra…
Si usa acute per l’accento acuto ovviamente…
Insomma, IMHO scrivendo in html ci si perde due minuti in più, ma si risparmia tanto tempo nel correggere le follie di certi editor baldracchi, e soprattutto ci si assicura la totale compatibilità…

pseudotecnico | #

@Davidonzo: se codifichi la pagina in UTF-8 non devi usare le entità per le lettere accentate.

Non hai notato che questa pagina è valida pur avendo le lettere accentate? 😉

kOoLiNuS | #

@pseudotecnico: mi contatteresti in privato ? visto il down del nostro hosting non ho modo di contattarti altrimenti.

koolinus { AT } gmail

@AB, scusa se faccio un uso privato della tua res publica!