Andrea Beggi

Run when you can, walk if you have to, crawl if you must; just never give up.

WordPress 2.5.1

A T T E N Z I O N E ! Questo post ha piu' di sei mesi. Le informazioni contenute potrebbero non essere aggiornate.

WordPress logoHo atteso la versione 2.5.1 poi mi sono deciso ad aggiornare un po’ di WordPress. La procedura di aggiornamento è sostanzialmente simile a quella delle versioni precedenti; bisogna avere l’accortezza di utilizzare il wp-config.php esistente evitando di modificare il wp-config-sample.php presente nel pacchetto di installazione. Ho aggiornato blog ospitati da tre diversi provider senza grossi inconvenienti, tranne che per qualche incompatibilità tra alcuni plugin e WebPerTe. In particolare su questo hosting non riesco a far funzionare il bellissimo BackUpWordPress per alcuni problemi di permessi sui file creati. Ho un ticket in lavorazione, vediamo se si riesce a risolvere. Nel frattempo uso wp-db-backup oppure lo script phpMyBackupPro che non è un plugin ma funziona abbastanza bene; la schedulazione del processo è facile da gestire tramite un include nel template o un wget pianificato su un altro server (io ho fatto così).

Sulla nuova interfaccia di amministrazione devo ancora riflettere, secondo me piuttosto che mettere le stesse cose in posti diversi (Office 2007? Vista?) sarebbe stato meglio aggiungere nuove funzioni. In ogni caso la trovo più caotica di prima: le cose mi sembrano disposte a caso sull’interfaccia, ma probabilmente mi devo ancora abituare. Inspiegabilmente, dalla dashboard è sparito il numero totale dei commenti, ma dovrebbe riapparire dalla prossima versione. In compenso mi funziona finalmente la visualizzazione dei tag in fondo al post, grazie alla nuova versione di Simple Tag. Su un blog non riesco a creare nuovi utenti: indagherò.

(logo credits)

14 Commenti

Tambu | #

mi accorgo solo ora che il logo di wordpress è terribilmente IDENTICO a quello della Wolksvagen 🙂

blau | #

wp 2.5 in generale difetta nella collaborazione tra utenti di un blog di gruppo, e nell’amministrazione utenti come ho scritto qui:
http://monsterlippa.info/2008/04/18/non-mi-piace-wordpress-25/
la versione 2.5.1 risolve un po’ di bachi, ma ne lascia aperto uno che impedisce il recupero (reset) della password da parte di un utente.
aspetterò finché non leggerò un advisory di scurezza importante.

Gatto Nero | #

Perché usare il vecchio wp-config, e non modificare il nuovo wp-config?
E’ l’unica cosa che non mi risulta chiara del tuo post.
Riguardo l’interfaccia: all’inizio, bisogna ammetterlo, lascia spiazzati. Ma penso sia per questioni di abitudine.
Alla lunga ti ci abitui: l’ho installata su un paio di progetti paralleli, e la trovo abbastanza comoda: da un lato hai le opzioni di scrittura, dall’altro quelle di gestione. Io, da questo punto di vista, avrei spostato “Design” sulla destra, però.

Stefano Aglietti | #

Aggiungerei all’articolo la necessità di modificare il wp-config per aggiungere la nuova SECRET_KEY fondamentale per migliorare la sicurezza con il nuovo sistema di codifica dei cookies.

@blau la 2.5.1 corregge un baco di sicurezza importante, la 2.3.3 è vurnerabile e recentemente si hanno diversi blog con una sorta di virus, il baco sulle password è già corretto sul trunk SVN e qualcuno ha reso disponibile i file patchati come segnalato in questo articolo:

http://www.wordpress-it.it/2008/04/27/wp-251-e-il-reset-della-password/

Andrea | #

effemmeffe: over perché le altre cartelle le devi cancellare prima di fare l’upload delle nuove.
Gatto: nel nuovo wp-config.php ci sono dei parametri in più che a me hanno creato problemi.
Steve, grazie…

Domiziano Galia | #

Io con la 2.5 andavo quasi sempre in 500 Internal server error quando pubblicavo o modificavo un post, con la 2.5.1 per ora (pare di) no.

Circa la nuova interfaccia: la pagina di gestione dei widgets è allucinante e macchinosa. Nel complesso tutta l’interfaccia è meno usabile della precedente, secondo me.

vitocola | #

Io l’ho montata e smontata, per il momento aspetto ancora un po’….

blau | #

Stefano, la falla di sicurezza chiusa da 2.5.1 riguarda, se non erro, i “registered users” che possono cerare altri utenti a piacere (6662): non mi riguarda, fortunatamente perché non ne ho, ed è un baco di 2.5 soltanto.
Dire che la 2.3.3 “è vulnerabile” è vago,potresti essere più specifico? Mi risulta un baco dell’importer da wp e da mt (5837), che non mi pone problemi immediati.
Infine, so bene che in trunk è stato chiuso il baco del password reset di 2.5.1, ma è mia abitudine usare le versioni nei tag, non trunk. Immagino che a breve vedremo 2.5.2.

AIUTO COMPUTER | #

Confermo anche per me il nuovo config da problemi di caratteri strano, il solito… Per il resto WP e’ un amore.

🙂

mpxnet | #

Ormai con WP gli aggiornamenti sono all’ordine del giorno.

Sergio | #

Ciao!
Ho aggiornato il sito alla 2.5.1 ed ho notato che la cancellazione di un utente genera una strana pagina di errore. Sembra che la procedura non funzioni, ma in realtà l’utente viene cancellato comunque. Avete provato se succede anche a voi?

Fabs | #

Aiutocomputer, anche a me ha dato caratteri strani. Devi correggere la riga:

define(‘DB_CHARSET’, ‘utf8’);

con la codifica usata dal tuo db. Io sono in hosting su Register.it e quindi ho inserito:

define(‘DB_CHARSET’, ‘ISO-8859-1’);